Vuelo de pruebas

Tema en 'Arduino / Multiwii' iniciado por jmuniesa, 21 Abr 2015.

  1. jmuniesa Nuevo Miembro

    jmuniesa
    Registrado:
    25 Feb 2014
    Mensajes:
    20
    Me Gusta recibidos:
    0
    Hola,

    tras montar un cuadricóptero basado en arduino mega (aeroquad) he empezado a hacer algunas pruebas.

    En las pruebas que he hecho observo que el bicho siempre se va hacia la izquierda cuando únicamente le doy gas para elevarlo.

    En los vídeos adjuntos no hay nada de viento, por lo que ese factor queda descartado.

    He revisado la configuración, correcto giro de los motores, hélices correctas, sensores bien configurados (en apariencia), en fin... que no se a que es debido ni qué hacer para corregirlo.

    En este primer vídeo (del mes pasado) podéis observar como se va para la izquierda. En ese caso lo achaqué al viento.

    [ame]https://www.youtube.com/watch?v=ZCEjZ7a-TsA[/ame]

    En ese segundo vídeo no había nada de viento y también se va a la izquierda (fijaos cómo se inclina un poco a la izquierda justo antes de despegar):

    [ame]https://www.youtube.com/watch?v=H8uOfCHvaEs[/ame]

    En este último vídeo, al dar gas giré (a la vez) un poco a la derecha para contrarrestar el efecto, pero aún así, se hace difícil de controlar (se sigue yendo un poco a la izquierda)

    [ame]https://www.youtube.com/watch?v=ysEqP8-hUDA[/ame]

    Si os fijáis en los tres vídeos, solo despegar ya se inclina un poco hacia la izquierda ...

    Podría ser un problema de PID?

    Se os ocurre qué podría hacer o revisar?
    muchas gracias.-
     
  2. jmuniesa Nuevo Miembro

    jmuniesa
    Registrado:
    25 Feb 2014
    Mensajes:
    20
    Me Gusta recibidos:
    0
    Algún consejo/comentario sobre este problemilla?
    gracias.-
     
  3. MerlinReady Nuevo Miembro

    MerlinReady
    Registrado:
    12 Mar 2015
    Mensajes:
    42
    Me Gusta recibidos:
    0
    No me hagas mucho caso por que yo estoy igual pero los trims de la emisora los has probado ?
     
  4. Chus47 Nuevo Miembro

    Chus47
    Registrado:
    30 Nov 2012
    Mensajes:
    75
    Me Gusta recibidos:
    0
    Pudiera ser que no hiciste bien las inclinaciones de la placa para los sensores y no esten bien ajustados.
     
  5. spike Miembro

    spike
    Registrado:
    29 Nov 2014
    Mensajes:
    185
    Me Gusta recibidos:
    0
    Has probado a hacerle el autotune???
    creo que eso te puede corregir algo el problema
     
  6. victor1988es Nuevo Miembro

    victor1988es
    Registrado:
    2 Feb 2015
    Mensajes:
    39
    Me Gusta recibidos:
    0
    repetir calibracion y tenerlo bien estatico
    para ver si es izquerda de verdad y no es es viento, rotalo y levantalo, se deberia ir hacia la izquierda aun con viento
     
  7. ardufriki Miembro

    ardufriki
    Registrado:
    12 Mar 2014
    Mensajes:
    651
    Me Gusta recibidos:
    1
    Según mi corta experiencia, pero si te puede ayudar:

    - comprueba muy bien paralelismo de motores. En concreto de ejes, que no tengas alguno doblado o un motor mirando a murcia... Cualquier problema aquí te producirá esas derivas. A veces en vez de derivar a un lado, se va girando él solo, aunque si llevas brújula y lo tienes fijado eso no lo notarás.

    - en relación con lo anterior, pudiera ser que alguno de los brazos esté doblado o rajado (no sé que materiales lleva tu quad). O que la estructura central esté torcida...comprueba esto.

    - si todo lo anterior está bien y los ESCs está calibrados, y has hecho bien las calibraciones de acelerómetros, gyros y brújula, eso tiene que subir recto. Una pequeña deriva de todas formas la corriges con los trims de la emisora y a volar.

    suerte.
     
  8. ardufriki Miembro

    ardufriki
    Registrado:
    12 Mar 2014
    Mensajes:
    651
    Me Gusta recibidos:
    1
    Te diré que a mí me vuela incluso mezclando hélices de distintos tamaños. Por eso no te he puesto nada sobre las hélices. Si están desequilibradas tendrás vibraciones, pero no derivas como la del video.
     
  9. victor1988es Nuevo Miembro

    victor1988es
    Registrado:
    2 Feb 2015
    Mensajes:
    39
    Me Gusta recibidos:
    0
    Jmuniesa como has quedado?? Vuela?
     

Compartir esta página