Variadores Crius SE

Tema en 'Electrónica General Multirrotor' iniciado por hermes, 18 Abr 2013.

  1. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Hola a todos! A ver si alguien puede echarme un cable. Veréis, mi Crius SE me estaba funcionando bien, tenía los cuatro variadores configurados y me funcionaban perfectamente. Ayer cambié el firmware para activar el gimbal, y ahora el gimbal me va de puta madre pero los variadores no me funcionan (no me arrancan los motores). No sé si tengo que tocar algo en el config (máximo y mínimo del acelerador y MINCOMAND) o hacer algo para que la placa detecte el máximo y el mínimo de los variadores.
    ¿Alguien sabe qué tengo que hacer para que me vuelvan a funcionar si están los cuatro variadores configurados? Muchas gracias!!

    Pd. Cuando conecto los variadores individualmente al receptor funcionan sin problema, pero si los vuelvo a conectar a la placa dejan de funcionar.
     
    #1 hermes, 18 Abr 2013
    Última edición: 18 Abr 2013
  2. fenestrone Nuevo Miembro

    fenestrone
    Registrado:
    3 Feb 2012
    Mensajes:
    96
    Me Gusta recibidos:
    0
    sin tener ni idea de como funciona esta placa...... normalmente las controladoras cada vez que se cambia el firmware debe volverse a reconfigurar todo partiendo de cero. asi pues, has vuelto a ajustar los variadores con la placa?
     
  3. monzon Maestro FPV

    monzon
    Registrado:
    24 Feb 2011
    Mensajes:
    2.352
    Me Gusta recibidos:
    0
    en el codigo has marcado el gimbal y xquad ??
    has marcado tu placa cirus se ??
    saludos
     
  4. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Hola Monzon.pues te cuento,he marcado gimbal,crius se y cuadx pero asi solo funciona el gimbal y los variadores se quedan muertos,y entonces vuelvo a cargar el firmware pero sin marcar el gimbal y asi funcionan los variadores (y motores claro) pero claro,sin el gimbal.Esto es pa volverse locooos!!
     
  5. rortega Gurú FPV

    rortega
    Registrado:
    20 Abr 2012
    Mensajes:
    5.535
    Me Gusta recibidos:
    4
    Supongo que los pines para el gimbal están definidos correctamente de modo que no se estén pisando pines de los motores. Revisa por si hay algún problema con la masa común. Prueba a no conectar el pin gnd de los variadoes, conectando únicamente el pin blanco de señal, eso sí, siempre que no estés alimentando la controladora desde los variadores.
     
  6. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Hola rortega.Tengo la controladora alimentada por un solo variador asi que supongo que a ese tendre que dejarle la masa pero entonces a los otros se las podria quitar no?,quiero decir,dejarle solo la señal.Y en cuanto a los pins de los servos,creo que estan bien porque cuando cargue el firm 2.0 con el gimbal+quadx definidos este funcionaba perfectamente pero claro,los variadores(motores) nada,solo el "piririi" inicial.Ahora tengo el firm 2.0 sin el gimbal definido y para ir probando el frame que he construido con unos grados de inclinacion en los motores para,ya sabes,evitar turbulencias en los descensos y hoy lo he probado y la verdad es que se nota bastante mejoria,lo aconsejo(y no he notado perdida de potencia por cambiar el vector de empuje).
    Estoy deseando de poder activar esto del gimbal porque es que me come la cabezaa to el dia,jeje.
    Seguid asi xicos que seguro vuestra experiencia podra sacarme de este "pozo de ignorancia" en el que estoy.(menudo titulo pa una peli,tio!!)
     
  7. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Ah,otra cosa con respecto al gimbal.Vereis,cuando cargo el firm con el gimbal definido aun sin conectar este,los variadores no funcionan (lo digo por lo de los pins rortega),y cuando lo vuelvo a cargar sin el gimbal definido el quad resucita asi que creo (y me aventuro muxo a decir esto por mi ignorancia en programacion con arduino) que algo cambia en el firm cuando defino el gimbal que afecta a los variadores (que me perdonen los entendidos en la materia si he dixo una burrada) :tongue2:.
    Por cierto,si alguien tiene su quadx con crius SE y el gimbal me podria pasar el firm que tiene para estudiar las variaciones con el mio a ver si soluciono algo y de paso probar este firm,igual funciona del tiron.GRACIAS de antemano tios.
     
  8. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Ehh xicos,lo he conseguidooo!!.
    A ver,para aquellos que estan sumidos en las tinieblas de lo desconocido y a punto de hacer volar la placa pero sin motores ni na,ya tengo activado el gimbal en el quadx con el firm 2.0...
    He de decir que uno de los servos (el del roll) no servia,no se porque y lo he cambiado por otro y ¡¡voila!!.
    -en el config solo marcar el tipo de frame (quadx),activar servotild y ajustar los recorridos y la ganancia del servo (eso despues de la primera prueba para saber que cambiar,claro).
    -en el multiwiiconfig activar el camstab en el aux1 en la posiciones que se desee (low,med,high).Yo lo tengo en todas para tenerlo siempre activo.

    Y eso es todo xicos!!,espero que os sirva a alguno de vosotros si teneis este mismo problema.Al menos a mi me funciona asi con esto que he hecho:laugh:.
    Gracias a todos por interesaros en mi problema tios!!
    ya pondre algunas fotos o video del bixo (aunque es un proto)jeje
     
  9. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    Aqui van esas fotos de el que me ha dado tanto dolor de cabeza,jeje...
    pero al final pude con el
     

    Adjuntos:

  10. hermes Nuevo Miembro

    hermes
    Registrado:
    14 Abr 2013
    Mensajes:
    15
    Me Gusta recibidos:
    0
    detalle de la inclinacion dada a los motores para mejor estabilidad en el descenso
     

    Adjuntos:

Compartir esta página