Ayuda! Tren aterrizaje con problemas

Tema en 'Chasis-Frames-Tren' iniciado por quequi, 18 Nov 2014.

  1. quequi Miembro

    quequi
    Registrado:
    10 Abr 2013
    Mensajes:
    107
    Me Gusta recibidos:
    0
    Hola,


    Tengo un tren de aterrizaje de multicóptero.
    Vamos a quitar de la ecuación las patas y los soportes, y me quedaré solo con el motor con su controladora y la carcasa donde se aloja todo.

    Partiendo de eso, es muy sencillo.

    Un motor con reductora y un eje largo roscado y en el eje largo roscado, un cilindro de aluminio con un agujero roscado, cuando el eje gira, el cilindro de aluminio avanza o retrocede.

    La controladora, tien 2 microswitch en cada extremo, cuando el cilindro de aluminio llega a un extremo, activa el interruptor y el motor se detiene, al mover el interruptor de la emisora a la otra posicion, el motor gira al reves, y el cilindro se desplaza hacia la otra punta, y cuando llega al otro microswitch, lo activa y se detiene, y asi cada vez.


    El problema es el siguiente.

    Vamos a hacer de cuenta que monto todo, y que utilizo la emisora para subir y bajar el tren.

    Le doy a la emisora tren arriba, y el tren sube.
    Le doy tren abajo y baja.
    Arriba y sube.
    Abajo y baja.
    .
    .
    .
    .
    Asi varias veces, pero en un momento, supongamos que le doy tren abajo, el tren baja unos centimetros y se detiene, si le doy tren arriba, continua bajando, a partir de ese momento, queda invertido el interruptor de la emisora con respecto a lo que hace el tren, hasta que en un momento, lo vuelve a hacer, y todo vuelve a la normalidad.

    Lo he probado con las patas individualmente, es decir solo conecto un tren al canal 5.

    Con los dos hace lo mismo.

    Es aleatorio el momento en que falla.

    El tren es este:

    http://www.banggood.com/HML850-Retr...ticopter-6-Axis-8-Axis-S800-EVO-p-917347.html

    El motor y controladora, para hacerse la idea, es como el de la foto que pongo.

    Alguna idea?
     

    Adjuntos:

    • Motor.jpg
      Motor.jpg
      Tamaño de archivo:
      4,1 KB
      Visitas:
      269
  2. Fred Gurú FPV

    Fred
    Registrado:
    26 Jun 2008
    Mensajes:
    3.659
    Me Gusta recibidos:
    1
    Mi idea es sera un de los microswitch que queda bloqueado en la posición cerrada.
     
  3. quequi Miembro

    quequi
    Registrado:
    10 Abr 2013
    Mensajes:
    107
    Me Gusta recibidos:
    0
    No.

    1) Lo hacen los 2 trenes, y me parece raro que fallen los dos en lo mismo.
    2) Si desmonto todo, y activo yo los switch con el dedo, aunque tenga un switch apretado, el cambio de direccion lo hace correctamente. O sea que puedo mantener el swith apretado durante todo el recorrido, y funciona correctamente.

    Gracias por responder
     
  4. Fred Gurú FPV

    Fred
    Registrado:
    26 Jun 2008
    Mensajes:
    3.659
    Me Gusta recibidos:
    1
    Lo siento no poder ayudarte más, es un caso curioso.
    Pensaba que seria el sistema convencional con dos switches y diodos en paralelo, y tu descripción concordia ...

    Suerte :smile:


     
  5. benemerit Miembro

    benemerit
    Registrado:
    14 Oct 2008
    Mensajes:
    718
    Me Gusta recibidos:
    0
    Ese tren es una autentica patata. Creo que el que diseño esa controladora se lució.

    Me explico. Tengo uno que tuve puesto unas semanas. Notaba cosas raras pero el colmo fue que en vuelo se invirtio una pata con lo que una subia una bajaba.... imaginate lo que sufri hasta aterrizar seguro.... pille el truco que es conmutar muy rapido y asi en una consegui que las dos patas fuesen parejas.

    Pues bien, despues de meses desmontado despues del susto lo he estado mirando hoy y ya se lo que le pasa. Tiene 2 problemas gordos:

    1.- Los switch detienen el motor cuando el brazo que esta en la varilla roscada llega a la posicion. Hasta ahi bien. Pero si apagas y enciendes el aparato, los motores arrancan en la misma direccion que tenia solo que al quedar bloqueados la controladora los para. El tema es que en los extremos llega un momento que la barra central se aprieta tanto a la barilla roscada y al tope que el motor no tiene fuerza para arrancar en posicion de salida lo que hace que el tren quede bloqueado y solo se desbloquee desmontandolo. Esto puede darse bien por que tenga un poco de holgura o por mal calculo en el mecanizado.

    Todo esto es porque el swich detiene el motor, pero solo una vez. Si queda pulsado y el motor vuelve a ponerse en la misma marcha el swich no lo para.

    2.- La inversion: Si el tren se queda bloqueado porque no puede moverse, por ejemplo le das con el aparato en tierra, la direccion de cierre se invierte. Pero ojo, que si uno arranca y el otro se bloquea ya lo tienes a la birulé.


    Cosas que me han pasado con este tren:
    Que al conectar bateria, como el tren esta parado en en una posicion con el stick de la barilla presionado se pone en marcha en esa misma direccion pudiendo bloquearse la barilla por apriete. Eso hace que si al golpe de stick no arranque, quede invertida la direccion de apertura/cierre

    Al final, tren a la basura. Creo que el que diseño la controladora se lució. En la mia pone v1 no se si sacaron otras.

    Ahora mismo estaba buscando otro modelo por la red..

    Suerte.
     
  6. quequi Miembro

    quequi
    Registrado:
    10 Abr 2013
    Mensajes:
    107
    Me Gusta recibidos:
    0
    Hola,

    Muchas gracias por responder.

    De momento, lo que he hecho es comprar controladora y motor de recambio, ademas, he modificado el cilindro metálico que hace actuar los switches, rellenándo con un poco de estaño, para asegurarme que el switch haga contacto, y de momento, sin problemas.

    Veremos con el tiempo a ver que pasa.

    un saludo
     

Compartir esta página