Problema Navy-Ctrl

Tema en 'Mikrokopter' iniciado por astorgato, 21 Oct 2010.

  1. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Vaya tengo un problemilla.

    Resulta que ya me decidi por actualizar la FC a la version 0.80 y no he tenido ningun problema ya la tengo a dicha version, he cambiado los setings y demas y todo hasta aqui perfecto. Ahora toca actualizar la Navy-Ctrl por los pines Debug y resulta que no comunica y me pone el famoso Time out. Los leds verde y rojo de la Navy estan constantemente encendidos y el Mk3mag esta tambien verde constante. A traves de los pines debug no consigo comunicar ni siquiera con la FC a traves del Mktools, y solo puedo comunicar con la FC directamente en su conector.

    A que puede ser devido.

    Un saludo gente.
     
  2. jfh900 Miembro

    jfh900
    Registrado:
    9 Oct 2010
    Mensajes:
    356
    Me Gusta recibidos:
    0
    Revisa que esté puesta la cinta plana que une la NC con la FC y que este
    bien introducida (como no tiene guía puede que algún pin haya quedado fuera). ¿Coincide el hilo rojo con los pines nº 1 de ambas placas?.

    Un saludo
     
  3. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Si coincide perfectamente, todos los pines en su sitio y las cintas planas en su correcta posicion.

    buff.

    [​IMG]
    By astorgato at 2010-08-25
     
  4. Phoenix Miembro

    Phoenix
    Registrado:
    6 Mar 2010
    Mensajes:
    144
    Me Gusta recibidos:
    0
    Buenos días,

    aunque no es exactamente lo que pone en el wiki, lo que funciona siempre (a no ser que tengas una avería de verdad oculta) es actualizar tanto la Navi como la FC a través de la Navi (si soltar ningun cable); primero actualizas la FC, luego la Navi y luego vuelves a actualizar la FC (es probable que la primera vez te husiese dado un error en el chequeo de los datos, por el desfase entre la nueva versión de la FC y la que tenia cargada en la Navi.

    Espero que te funcione. A mi me va perfectamente.

    Saludos,
     
  5. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    El tema es que a traves de la navy (Debug) no me conecta, los 2 leds del mkusb parpadean muy rapidamente cuando conecto a la navy, y no existe comunicacion.
     
  6. albertocvr Miembro Activo

    albertocvr
    Registrado:
    9 Abr 2007
    Mensajes:
    1.197
    Me Gusta recibidos:
    0
    Tienes que resetear el procesador de la navictrl , se te ha quedado colgado .
    No recuerdo de memoria pero mira en el esquema de la navi el pin de reset que va a tierra a traves de un condensador y lo puenteas cuando en el mktool intentes comunicar ( es solo un instante ) , despues ya puedes cargar otra vez el nuevo firmware.:wink:
     
  7. acristóbal Gurú FPV

    acristóbal
    Registrado:
    9 Oct 2006
    Mensajes:
    3.710
    Me Gusta recibidos:
    0
    Prueba a actualizarla y mientras esta intentando comunicar con el MKtool le quitas la alimentación a la Navy la vuelves a conectar, la mayoría de las veces funciona.

    Suerte.
    Alberto
     
  8. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    acristobal,

    Eso me paso con al FC y me funciono.

    albertocvr,

    Estoy intentando buscar ese pin de reset, donde esta el esquema de la navy en la wiki?

    Gracias majos, no sabeis que agobio ya sabiendo que llega el finde.
     
  9. acristóbal Gurú FPV

    acristóbal
    Registrado:
    9 Oct 2006
    Mensajes:
    3.710
    Me Gusta recibidos:
    0
    Eso le pasó a Rubens con la Navy y le funcionó.
     
  10. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Ya empezando porque no me conecta al mktools por el puerto debug y aunque le de a actualizar y en ese momento quite y ponga la bateria no obtengo resultados.
     
  11. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Esto es el resultado de poner la navy con el mkusb ella solita y el pin de alimentacion del mismo, abro el mktools, le doy a actualizar, selecciono el archivo etc, el tema es que se queda asi en reset...

    El led rojo queda fijo
    Que conclusion sacais de todo esto?




    [​IMG]
     
  12. trokola Miembro

    trokola
    Registrado:
    18 Dic 2008
    Mensajes:
    414
    Me Gusta recibidos:
    0
    Yo creo recordar que me ha pasado eso. Intenta flashearla con una version anterior (aunque sea la que tienes ya puesta) a ver si lo hace, y luego vuelve con esta. No recuerdo muy bien lo que hice, pero creo que algo de eso.
     
  13. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Trokola,

    La he pasado a una version anterior y me ha dejado. Pongo unas capturas de pantalla.


    [​IMG]

    [​IMG]
    By astorgato at 2010-10-21


    Al final he tenido que volver todo a las versiones anteriores, por lo menos ya tiene pinta de funcionar todo, lo dejare para otro momento.
     
    #13 astorgato, 22 Oct 2010
    Última edición: 22 Oct 2010
  14. acristóbal Gurú FPV

    acristóbal
    Registrado:
    9 Oct 2006
    Mensajes:
    3.710
    Me Gusta recibidos:
    0
    Haber aprovechado para meter la nueva ya que tenías todo listo, si no te entra ya lo harías más adelante.

    Buenos Vuelos
    Alberto
     
  15. trokola Miembro

    trokola
    Registrado:
    18 Dic 2008
    Mensajes:
    414
    Me Gusta recibidos:
    0
    Pues cuando lo vayas a hacer bájate de nuevo todos los ficheros e insiste que eso es lo que me paso a mi y no recuerdo haber hecho nada especial. Creo que borre todo, empece de nuevo con calma y funciono.
     
  16. astorgato Miembro

    astorgato
    Registrado:
    18 Dic 2006
    Mensajes:
    266
    Me Gusta recibidos:
    0
    Gracias gente por vuestra ayuda, ya consegui actualizar todo.

    Un saludo.
     

Compartir esta página