Problema con MultiWii PRO y Megapirate

Tema en 'Arduino / Multiwii' iniciado por mattogodoy, 18 Sep 2013.

  1. mattogodoy Nuevo Miembro

    mattogodoy
    Registrado:
    3 Jul 2013
    Mensajes:
    8
    Me Gusta recibidos:
    0
    Buenas!
    Soy nuevo en el foro y en el hobby :p
    Anoche terminé de montar mi primer quadcopter con una controladora de vuelo MultiWii Pro a la cual instalé Megapirate 2.8:
    http://hobbyking.com/hobbyking/stor...ontroller_w_MTK_GPS_Module_EU_warehouse_.html

    El problema es que al intentar hacerlo volar, el throttle está muy sensible, y a pequeños cambios en el stick, me genera aceleraciones bastante bruscas en el quad. Estoy usando una radio Turnigy 9x, en modo Heli (modo-2).

    Sorteando ese problema, lo elevo y apenas se despega del suelo, empieza a moverse bruscamente como desestabilizado, y no llego a hacer nada que empieza a elevarse solo y moviéndose para todos lados, como buscando estabilidad, pero los movimientos son tan bruscos que hasta me hizo un flip para el costado derecho!
    Le di tres porrazos (en el pasto) anoche haciendo pruebas, pero no me animo a hacer mas por miedo a romperlo.

    Los 4 ESCs están configurados con la tarjeta programadora de Turnigy, por lo que descarto que sea eso.

    Supongo que será un problema de configuración del transmisor, o del modo de vuelo de la multiwii, o de una combinación de ambas.

    Me podrán echar un poco de luz sobre el tema?
    Gracias!
     

    Adjuntos:

    #1 mattogodoy, 18 Sep 2013
    Última edición: 18 Sep 2013
  2. lazone Nuevo Miembro

    lazone
    Registrado:
    11 Sep 2012
    Mensajes:
    79
    Me Gusta recibidos:
    0
    Hola,
    Parece ser que tiene toda la pinta de que no tienes hecho bien el calibrado de los ESC. TE aconsejo que hagas el calibrado directamente en el canal 3 del receptor por cada ESC. Y luego revisa que tienes bien el sentido de giro de cada motor y sobre todo que cada motor es conectado a su canal correspondiente de la placa.
     
  3. mattogodoy Nuevo Miembro

    mattogodoy
    Registrado:
    3 Jul 2013
    Mensajes:
    8
    Me Gusta recibidos:
    0
    Gracias!
    Con el calibrado de cada uno de los ESCs mejoró 1000%
    Ahora me falta jugar con los PIDs para afinarlo.

    Algún consejo para ajustar PIDs?
     
  4. lazone Nuevo Miembro

    lazone
    Registrado:
    11 Sep 2012
    Mensajes:
    79
    Me Gusta recibidos:
    0
    Hola, me alegro de haberte ayudado. En cuanto al ajuste de los
    Pid no te puedo ayudar porque estoy terminando de instalar y configurar una crius aio pro v2. Y en ese campo soy igual novato que tu.
     

Compartir esta página