Problema APM 2.8

Tema en 'Arduino / Multiwii' iniciado por Josua, 20 May 2016.

  1. Josua Nuevo Miembro

    Josua
    Registrado:
    30 Dic 2012
    Mensajes:
    86
    Me Gusta recibidos:
    0
    Buenas:

    He puesto y configurado la APM a través del Mission Planner siguiendo videos de Youtube, comprobando que los motores giren a la vez, calibrando todo lo calibrable, sin embargo, no consigo que al encender la emisora y conectar la batería, se armen los motores, por lo que los motores sólo los veo moverse si hago la prueba de giro de los motores a través de la emisora, pero a través del Mission Planner no hace el test de motores.

    Agradecería cualquier orientación para poder solucionar el problema.

    Gracias

    Josua
     
  2. txan Miembro

    txan
    Registrado:
    9 May 2013
    Mensajes:
    143
    Me Gusta recibidos:
    0
    La luz roja de la apm que secuencia hace? 2 destellos rapidos o 1 lento despues del otro?
    De otra manera dicho, 2 destellos rojos por segundo o uno?
    Si te hace 2 es que hay algun problema de calibracion o configuracion


    Enviado desde mi gsxr1000 k7
     
  3. Josua Nuevo Miembro

    Josua
    Registrado:
    30 Dic 2012
    Mensajes:
    86
    Me Gusta recibidos:
    0
    He conseguido ya armar los motores, hace parpadeo intermitente rojo/azul y con el modo stabilize y mando gas abajo derecha, consigo poner en marcha los motores. Ahora el siguiente paso es la estabilidad, me da la sensación de que se va un poco hacia un lado el dron
     
  4. txan Miembro

    txan
    Registrado:
    9 May 2013
    Mensajes:
    143
    Me Gusta recibidos:
    0


    Claro!! Si no das abajo a la derecha mo te va a armar nunca....
    Cuando vayas a usar un modo con gps primero espera a que la luz azul quede fija, significa que ya a cogido satelites
     
  5. Josua Nuevo Miembro

    Josua
    Registrado:
    30 Dic 2012
    Mensajes:
    86
    Me Gusta recibidos:
    0
    El vuelo del f450 es inestable, tiende a irse un poco hacia atrás y hacia la izquierda, supongo que será tema de hacer una calibración más fina ¿verdad?
     
  6. dayanki Miembro Activo

    dayanki
    Registrado:
    19 Dic 2010
    Mensajes:
    1.483
    Me Gusta recibidos:
    0
    Hola. Si esto te pasa volando en Stabilize, puedes afinarlo con el Save Trim
     
  7. Josua Nuevo Miembro

    Josua
    Registrado:
    30 Dic 2012
    Mensajes:
    86
    Me Gusta recibidos:
    0
    En realidad con lo que más pasa es con el Loiter. Sólo probé el Stabilize, Loiter y RTL. El Stabilize también se desestabiliza, pero con el Loiter es bastante evidente, tanto que enseguida tengo que quitarlo y volver a manual porque estoy casi seguro que se estrellaría.
     
  8. dayanki Miembro Activo

    dayanki
    Registrado:
    19 Dic 2010
    Mensajes:
    1.483
    Me Gusta recibidos:
    0
    Si conectando el loiter el rotor empieza a hacer círculos, siempre mas grandes, quiere decir que tienes un problema de calibración de la brújula. No me acuerdo si la 2.8 lleva la brujula en la antena GPS, como la 2.6, o en la misma placa APM. Si la tienes en la antena GPS, levanta la antena lo mas posible, alejándola del frame, 10-12 cm son suficientes. Otro problema que puedes tener con este tipo de antena-brújula, es que haya un error en la colocación de la flecha en la carcasa de la antena (mira aquí)
    Si en cambio la brujula està colocada en la placa APM, tienes que hacer un Compass-Mot.
    Saludos
     
  9. txan Miembro

    txan
    Registrado:
    9 May 2013
    Mensajes:
    143
    Me Gusta recibidos:
    0
    La apm 2.8 si lleva brujula interna, lo mejor es anularla. Se anula quitando el jumper que hay al lado de la conexion del gps, se quita de ahi y en el mission planner le pones para usar la brujula externa. Y un compassmot no vendria mal para saber las interferencias.
    Por cierto dayanki, ya tengo en casa la capota del tarot...haber si me llega la pixhawk y lo monto todo ya de una vez...[emoji6][emoji6]


    Enviado desde mi gsxr1000 k7
     
  10. Josua Nuevo Miembro

    Josua
    Registrado:
    30 Dic 2012
    Mensajes:
    86
    Me Gusta recibidos:
    0
    Voy a comprobar todo lo que comentáis. Iba a sacar hoy a volar el multi, pero hace mucho aire por aquí, así que esperaré a otra oportunidad mejor y pondré en práctica lo que decís.

    Gracias por vuestra ayuda
     

Compartir esta página