Error I2C en multiwii

Tema en 'Arduino / Multiwii' iniciado por JagerFD, 1 Jul 2014.

  1. JagerFD Nuevo Miembro

    JagerFD
    Registrado:
    1 Jul 2014
    Mensajes:
    2
    Me Gusta recibidos:
    0
    Hola buenas, soy nuevo por aquí y ya tengo problemones

    Hace unos dias me llego mi pedido para un quad, con la placa de control multiwii (la típica roja de hobbyking). La cosa es que le cargue el código... todo perfe... monte todo el cacharro, hice unas pruebas pero creo que los motores no pueden con el peso total, así que tonteaba con la batería en el suelo (todo un imbécil, ya lo se..) y una de tantas el quad se dio la vuelta y rompió una hélice. Total que cambie la hélice pero desde entonces que la placa no funciona, me da error de I2C y se calienta una barbaridad. He estado leyendo y probando varias soluciones pero nada.
    A ver si me podéis ayudar, no me gustaría dejar esto tan pronto y con tan mal sabor de boca.
     
  2. isaacblazquez Miembro

    isaacblazquez
    Registrado:
    15 Jun 2013
    Mensajes:
    174
    Me Gusta recibidos:
    0
    Podrias dar mas datos sobre motores que usas... tamaño de palas... peso en orden de vuelo... que ESCs usas... Es raro que el quad no se despegue del suelo y se de la vuelta. Me suena a palas en orden incorrecto.

    Sobre los errores. Es raro que se te haya roto un componente por darse la vuelta ... quizás se ha chamuscado algo. Si se ha frito la placa no hace falta dejar el hobby. Solo cambio de placa y a volar.

    Da datos y podremos ayudarte.

    Saludos

    miembro de xcoptersevilla.es
     
  3. isaacblazquez Miembro

    isaacblazquez
    Registrado:
    15 Jun 2013
    Mensajes:
    174
    Me Gusta recibidos:
    0
    Por cierto no estaria mal que te pasaras a presentarte por el hilo de presentación del foro

    miembro de xcoptersevilla.es
     
  4. JagerFD Nuevo Miembro

    JagerFD
    Registrado:
    1 Jul 2014
    Mensajes:
    2
    Me Gusta recibidos:
    0
    Gracias por interesarte!!

    A ver comento la configuracion que monto.

    Motores: turnigy D2822/17 1100KV
    ESC: HobbyKing 18A
    Helices: 7x4.5 baratillas del HK
    Frame: el pequeño blanco y rojo del HK
    Bateria: Zippy compact 25C 2700 3cell 11.1v

    El tema placa me temo que esta frita... le cargo algún programa de arduino de prueba y funciona pero se calienta que parece una estufa...
    Y que no se levante puede q simplemente no lo hice bien, o también pienso q las palas parecían un tanto desequilibradas o.. la batería q sea de poca descarga "25C"
     
  5. monzon Maestro FPV

    monzon
    Registrado:
    24 Feb 2011
    Mensajes:
    2.352
    Me Gusta recibidos:
    0
    buenas , y bien venido , si se calienta algo esta en corto y de hay los fallos i2c,
    vamos a lo facil , conecta la placa por usb y con el dedio palpa haber que es lo que se calienta , foto marca y seguimos .
    si se ha dado un golpe puede haberse jodido un sensor o un micro . duras son de narices , mas porras que le he dado yo y estan perfe imposible .
    has desconectado todo de la placa , ??
    has eso solo placa sin ningun esc ni nada conectado haber que se calienta , pues puede ser simplemmnete el retificador a 5v o 3.3 o quien sabe .
     

Compartir esta página