Error 22#restart motor

Tema en 'Mikrokopter' iniciado por Rodeval, 17 Feb 2013.

  1. Rodeval Miembro

    Rodeval
    Registrado:
    20 Feb 2011
    Mensajes:
    133
    Me Gusta recibidos:
    0
    Hola de nuevo,

    He montado un nuevo octo y le hice volar el fin de semana pasado un rato.
    Voló muy bien a falta de afinar cosilllas. De repente, me falló uno de los motores y me aparecía error 22 y la pantalla del osd en rojo. y el motor nº 5 fallaba y no llegaba a arrancar.
    Alguna de las veces me daba la sensación que algunos motores iban a menos revoluciones y no llegaban a arrancar bien.
    el caso es que pasó a revisión y no veo nada raro, aparte de ser mas malo que la quina con el soldador.

    Hoy me disponia a cambiar el variador y he hecho mas pruebas antes. Y coño, ahora me fallan otros motores y no siempre.
    Tengo los variadores negros y como sabeis te dan los datos de consumo y temperatura en la pantalla del MK osd. resulta que me he dado cuenta que al arrancar, algunos de estos datos se ponen en amarillo y al pasar un par de segundos se ponen en blanco. es aleatorio, cada vez se ponen unos u otros.

    Con el octo sin helices, he arrancado todo y he ido parando un poco los motores con la mano y resulta que en una de las pruebas dos de ellos, que por desgracia no son los mismos que me daban el problema el fin de semana pasado los paraba con solo mirarlos y me daba el mismo error.
    He vuelto a reiniciar todo y he repetido la prueba. Se han puesto algunos de los variadores en amarillo de nuevo, pero no se ha vuelto a repetir el error. todos los motores tienen la misma fuerza.

    Los motores utilizando el motor test también van bien y como bestias.

    Ahora las preguntas

    Porque se ponen en amarillos los variadores en el OSD?Y por que no se ponen todos en amarillo al arrancar?

    A que se puede deber eso de error 22 para que no se repita siempre en el mismo motor y solo ocurra algunas ocasiones?


    Muchas gracias y si me podéis responder que sea para tontos.

    Roberto
     
  2. Rodeval Miembro

    Rodeval
    Registrado:
    20 Feb 2011
    Mensajes:
    133
    Me Gusta recibidos:
    0
    Perdón error de método.
    Todos los motores van bien, antes se me había movido la fc.

    El error es ERROR 23, no el 22.

    lo he arrancado un montón de veces y no lo hace mas pero si se ponen los datos en amarillo.

    Saludos
     
  3. helirap1 Miembro Activo

    helirap1
    Registrado:
    17 Oct 2006
    Mensajes:
    1.711
    Me Gusta recibidos:
    0
    Mira esto a ver si te ayuda:

    http://www.mikrokopter.de/ucwiki/en/ErrorCodes#A23_.22Motor_restart.22


    error 23 "Motor restart"

    One BL-Controller tries to restart the motor
    motor blocked od defect motor cable

    traduccion chapucera:
    Un BL-Controller intenta reiniciar el motor
    motor bloqueado o defecto del cable del motor

    si puedes, desconecta el I2c de los variadores y prueba uno por uno comprobando si se quita el error, a ver si tienes suerte.
     
  4. Rodeval Miembro

    Rodeval
    Registrado:
    20 Feb 2011
    Mensajes:
    133
    Me Gusta recibidos:
    0
    gracias,
    Eso es lo que había visto pero no me aclaraba mucho.

    Creo que va a ser mas fácil de lo que pensaba, estoy probando una cosas, luego os cuento.

    Saludos y gracias.

    Por cierto de lo de los datos de los variadores en amarillo?
     
  5. Rodeval Miembro

    Rodeval
    Registrado:
    20 Feb 2011
    Mensajes:
    133
    Me Gusta recibidos:
    0
    Creo que es un tema mecánico.

    Me parece que no tengo la fc lo suficientemente plana y al arrancar, el motor 5 el que está atrás, entiende que esta mas alto que los demás y se ralentiza un poco.
    Como llevo hélices de 14"no tiene fuerza para girar y hasta que no acelero todo me da error.

    Sigo investigando, pero me temo que va por ahí la cosa.

    Saludos

    Roberto
     

Compartir esta página