Diseño y control de un UAV

Tema en 'R/C Diseño Aviones FPV & UAV' iniciado por mapetilan, 1 Mar 2011.

  1. mapetilan Nuevo Miembro

    mapetilan
    Registrado:
    1 Mar 2011
    Mensajes:
    1
    Me Gusta recibidos:
    0
    Hola a todos,

    Estoy dentro de la Asociación de Robótica de la Universidad Carlos III de Madrid y estamos diseñando un UAV. Hemos comprado el quadcopter Quad X600D y le hemos quitado el receptor de RF y en su lugar hemos puesto una placa especializada de robótica que se llama Roboard, con ello queremos controlar el UAV desde un ordenador, os dejo el esquema:
    http://asrob.uc3m.es/w/index.php/Arquitectura_de_control_del_UAV

    Para mover el quad, lo que hacemos es introducir señales PWM al estabilizador
    (que es lo que haría el receptor RF), pero nosotros las generamos con la placa Roboard.

    Os planteo una dudas a ver si alguien nos sabe ayudar:

    Cada poco el quad se pone a pitar, ¿alguien sabe por qué es y cómo se soluciona?

    Un saludo y muchas gracias
     
  2. juan ruiz Moderator

    juan ruiz
    Registrado:
    25 Sep 2006
    Mensajes:
    3.040
    Me Gusta recibidos:
    0
    Tendrias que poner algunas cosas mas.

    Motores y el consumo de ellos.

    Baterias que usas,voltios y descarga.

    A volado alguna vez o es meter corriente y ya tienes los pitidos.

    Falta de señal PWM.

    ¿Esta programado para cambiar la señal RF por PWM.?

    ¿Lo dejais reposar unos segundos sin tocarlo para que los giroscopios se estabilicen,totalmente a nivel?


    Saludos
     
  3. cacer Miembro Activo

    cacer
    Registrado:
    3 Ene 2008
    Mensajes:
    1.136
    Me Gusta recibidos:
    0
    Primero, es norma del foro y una buena practica, presentarse antes de lanzar preguntas en el hilo correspondiente.

    En segundo lugas, como tambien es norma del foro ayudar a todo el que lo necesita, intentamos entender lo que haces.

    1) En el esquema que montas, pones la imagen de la KK, supongo que es solo por usar una imagen, de la misma forma que metes un router en lugar de un receptor.

    Si la electronica que usas es la propia del X600D, me dá la sensación que lo que escuchas son los variadores indicando que no está armado, aunque tambien puede ser como bien dice Juan, que no recibe o entiende la señal PWM que estais enviandole. Como este Quad, usa un programa de control para configurarlo y te dá mucha información al respecto, te recomiendo que lo usues mientras pruebas, al objeto de informar que sale en el y si te reconoce o no el receptor, en este caso la Roboard.
     
  4. jfh900 Miembro

    jfh900
    Registrado:
    9 Oct 2010
    Mensajes:
    356
    Me Gusta recibidos:
    0
    Ojo a las latencias de las señales, puede suceder que la trama le llegue a la controladora con mucho retraso y considere que no tiene trama. Deberías de dar más información.

    Un saludo
     
  5. elossam Maestro FPV

    elossam
    Registrado:
    6 Oct 2006
    Mensajes:
    2.812
    Me Gusta recibidos:
    0
    Pero se sabe que es lo que pita: ¿Los variadores, los motores, la placa mezcladora, otros... ?
     
  6. sircana Miembro Activo

    sircana
    Registrado:
    9 Dic 2010
    Mensajes:
    1.393
    Me Gusta recibidos:
    0
    Pues a bote pronto yo opino lo mismo. Prueba a poner los motores en marcha, a baja velocidad, a ver si deja de pitar.
     

Compartir esta página