Variadores Ayuda variadores y placa conversora pwm

Tema en 'Mikrokopter' iniciado por vicent99, 10 Abr 2013.

  1. vicent99 Nuevo Miembro

    vicent99
    Registrado:
    10 Abr 2013
    Mensajes:
    10
    Me Gusta recibidos:
    0
    Hola , me presento soy Vicente y he heredado un MK quadcopter con todas las placas la navi la flight la mag y la gps .

    Tras unos pocos vuelso hoy e han petado 3 variadores y al compañero que le tenia antes le petaron otros tantos asique despues de leer algo de una placa conversora queria que alguien me dijera cual comprar y unos variadores para el.

    La placa imagino que no se puede comprar en españa pero los variadores si me gustaria que fueran en españa y a ser posible que vengan listos para enchufar y usar.

    un saludo
     
  2. Petertel Miembro Activo

    Petertel
    Registrado:
    3 Sep 2009
    Mensajes:
    1.363
    Me Gusta recibidos:
    0
    Hola Vicente, en este post: http://www.aeromodelismovirtual.com/showthread.php?t=10468&highlight=low+cost tienes bastante información sobre el conversor I2C-PWM que quieres poner.

    Sobre la avería de los variadores no es fácil dar un veredicto sin mas datos y con la bola del cristal averiada :laugh::laugh::laugh:, pero a grandes rasgos si te han petado los mosfet tienes un problema de sobreconsumo o mal conexionado entre variadores y motores, y si lo que se te joden son los micros entonces seguro que tienes un mal contacto en la línea del bus I2C.

    Un saludo.
     
  3. vicent99 Nuevo Miembro

    vicent99
    Registrado:
    10 Abr 2013
    Mensajes:
    10
    Me Gusta recibidos:
    0
    Hola , mira te comento este Quad lo herede de un compañero y estaba tan mal cableado y con soldaduras tan mal hechas que decidi cablearlo entero.

    para el cable i2c use cable de servo normal agrupando las C y las D en un conector de banana de 3 mm para poder desconectarlo de la placa facilmente.

    la conexion de los variadores y los motores es mediante bananas de 2mmm.

    los motores son los roxxy 2827-34 con helices 10x4,5 a 4S.

    antes de montar la electronica en el chasis que es cerrado decidi montarlo todo encima de la mesa y probar .

    al principio me daba error de comunicacion I2c y cabiando uno de los variadores por otro se soluciono .

    Estuve haciendo uno por uno el test de motores con mktools sin ningun problema y despues de desconectar al rato fui a enchufar para ver un parametro y peto un variador que a simple vista tiene lo mismo que esta foto

    http://www.aeromodelismovirtual.com/attachment.php?attachmentid=37197&d=1352824186

    sin embargo hay otros dos que no funcionan ( No se les encienden los leds ) , pero aparentemente no tienen nada.

    El variador que ha petado es de los rojos antiguos.

    LLevo un interruptor tbs creo que se llama que se supone que evitaba esto pero aun asi mi compañero me dijo que tambien le petaron algunos.

    Ya que tengo informacion de la placa , la pregunta es por que ha petado ese variador si tiene arreglo y que le peude pasar a los otros dos.


    un saludo
     
  4. Petertel Miembro Activo

    Petertel
    Registrado:
    3 Sep 2009
    Mensajes:
    1.363
    Me Gusta recibidos:
    0
    Hola, lo que tiene roto ese variador es el shunt de sensor de corriente, y la reparación no es muy buena, ya que si vuelves a resoldar el shunt el variador te funcionará, pero como le varias la resistencia ya no te va a sensar bien la corriente y te dará valores erroneos o incluso he tenido casos que se negaban a arrancar porque pensaban que les pasaba mas corriente que la que realmente circula.

    Y los que no te encienden las luces, ya te comenté que tendrás seguramente jodidos los micros, esa avería es mas fácil de reparar, siempre y cuando sepas cambiar los integrados y jodas nada mas en el intento... luego los flaseas y ha funcionar. Si no te atreves y me los quieres mandar te daré precios por privado.

    Un saludo.
     

Compartir esta página