APM 2.6 en micro RCX

Tema en 'Arduino / Multiwii' iniciado por chapulino, 21 Ago 2014.

  1. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    He montado un micro con esta placa
    En principio ya tengo unos ajustes PIDS aceptables. podre mejorarlos pero me he encallado con la funcion alt hold y loiter. no marchan bien .
    Cuando paso a Loiter a mitad de gas , el mini no estabiliza la altura, o se pone a subir o desciende.
    LA primera opcion fue tapar todos las entradas de aire de la caja de la placa a excepcion de la del usb para evitar la entrada de aire que produce el hecho de que las palas estén tan cerca de la placa .

    La situacion mejoro un poco pero sigue sin ser satisfactoria,


    Alguien tiene experiencia con esta placa en un micro?

    Os dejo unas fotos, igual mañana preparo un video a ver si alguien me ilumina.

    gracias.



    https://dl.dropboxusercontent.com/u/53933295/IMG_20140820_213834.jpg
    https://dl.dropboxusercontent.com/u/53933295/IMG_20140820_213909.jpg
    https://dl.dropboxusercontent.com/u/53933295/IMG_20140820_213934.jpg
     
  2. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    Nadie me da una idea de por donde mirar?
     
  3. juanjojjjjjj Miembro

    juanjojjjjjj
    Registrado:
    10 Ene 2014
    Mensajes:
    350
    Me Gusta recibidos:
    0
    Yo tengo un micro con esta placa.
    Tienes que ajustar el centro del acelerador para que en el punto medio el micro se quede flotan, y de esta manera cuando pongas el modo mantener altura no te suba o baje.
    En modo altura hay un punto muerto entre el 40 y 60% del acelerador y es hay donde más o menos tiene que mantenerse en el modo estabilidad.
     
  4. juanjojjjjjj Miembro

    juanjojjjjjj
    Registrado:
    10 Ene 2014
    Mensajes:
    350
    Me Gusta recibidos:
    0
    APM 2.6 PRIMERA PRUEBA: [ame]http://youtu.be/mAdXECecXVQ[/ame]
     
  5. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    A ver un alma caritava que me ayude con la configuracion de mi micro con APM.

    Los pid de roll , pitch y yaw, ya me tiene mas o menos convencido pero sigo si ajustar o la combinacion palca micro no va bien Alt Hold y consecuentemente el loiter.

    os dejo todo lo que considero necesario para analizar la situacion .
    Un video ,
    Las configuraciones de la placa, un pantallazo del log con los parametros de altitud y el log del vuelo.

    Por donde puede venir el problema ?

    Gracias de antemano.

    Nota: el video es de una SJ4000 pero editado con el program de la Gopro ;-)

    log micro pruebas alt hold
    [​IMG]
    https://www.dropbox.com/s/xx1w5s5volnslpo/Captura de pantalla 2014-08-30 20.48.30.png?dl=0
    El log completo
    https://www.dropbox.com/s/1pnii47rty0zm8w/2014-08-30 20-28-50.log?dl=0

    configuracion basica
    [​IMG]
    https://www.dropbox.com/s/ipl3dsydinzx3r0/Captura de pantalla 2014-08-30 20.55.27.png?dl=0
    Extender tuning
    [​IMG]
    https://www.dropbox.com/s/q0uw81fqjmj3io2/Captura de pantalla 2014-08-30 20.56.25.png?dl=0

    y por ultimo un video :

    pongo el enlace cuando este descargado
     
  6. juanjojjjjjj Miembro

    juanjojjjjjj
    Registrado:
    10 Ene 2014
    Mensajes:
    350
    Me Gusta recibidos:
    0
    Mandame privado con tu WhatsApp y te hecho una mano.
    Yo por fin deje el mio fino.
    Tuve muchos ploblema con los pid, es muy diferente un micro con la apm a un cuad grande.
    Mira como quedo de fino y responde que da miedo.
    En loiter se clava.
    Microquad 2°vuelo: [ame]http://youtu.be/DnVTNHPYg_E[/ame]
     
  7. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    No tengo whasap pero no me importa llamarte mañana por teléfono que hora te viene bien?
    Te paso mi teléfono por privado
     
  8. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    El video

     
    #8 chapulino, 31 Ago 2014
    Última edición: 31 Ago 2014
  9. chapulino Miembro

    chapulino
    Registrado:
    20 Nov 2013
    Mensajes:
    248
    Me Gusta recibidos:
    0
    Bueno comento avances ,

    Despues de una conversacion con el amigo Juanjojj reflexioné sobre varias consas. mejoré el aislamiento a vibraciones de la placa con una soporte antibrivaciones que tenia y ademas esto ha elevado la placa por encima de la linea de Helices por lo que ahora ya me funciona el Halt Hold y el loiter , ahora podre hacer un autopid y reajustar despues.

    Gracias

    Os voy contando.
     
  10. juanjojjjjjj Miembro

    juanjojjjjjj
    Registrado:
    10 Ene 2014
    Mensajes:
    350
    Me Gusta recibidos:
    0
    Me alegro mucho:D:D:D:D:D:D
     

Compartir esta página