Ajustes GPS-NAV Mikrokopter

Tema en 'Mikrokopter' iniciado por trokola, 27 Jul 2010.

  1. trokola Miembro

    trokola
    Registrado:
    18 Dic 2008
    Mensajes:
    414
    Me Gusta recibidos:
    0
    Hola a todos:

    ¿Alguien experimentado puede poner a grandes rasgos como ajustar los parametros del GPS-NAV en el MK para afinar la navegacion y el Position Hold?

    Mi hexa por ejemplo, a veces el PH parece que va bastante bien y a veces el Hexa al activarlo se pone a describir circulos mas o menos grandes alrededor de la posicion. Creo que funciona mejor cuando hace algo de viento que cuando hay calma total.

    Ya se que sera cuestion de ajustar los parametros de ganancia, P, I, D, etc, pero si alguien tiene algunas nociones para ir modificando valores con algun criterio y entender como afecta cada parametro al comportamiento ....

    Muchas gracias a todos.
     
    #1 trokola, 27 Jul 2010
    Última edición por un moderador: 5 Dic 2011
  2. espariz Miembro

    espariz
    Registrado:
    26 Feb 2007
    Mensajes:
    848
    Me Gusta recibidos:
    0
    Hola, pon GPS-P a 100, y CORRECCION VIENTO GPS a 100 tambien, a ver que tal...

    Para lo de los círculos, creo que si haces de nuevo todo lo cuidadoso que puedas el calibrado de la MK3MAG te lo hará menos, saludos!

    Alberto
     
  3. trokola Miembro

    trokola
    Registrado:
    18 Dic 2008
    Mensajes:
    414
    Me Gusta recibidos:
    0
    Gracias Alberto. He estado probando valores diferentes de PID asignandolo a un poti y ya he visto como varia la cosa y he podido ajustarlo bastante, aunque sigue con los circulos a veces. Finalmente he leido por ahi que es importante que la brujula este muy bien calibrada y apunte exactemente al norte (+- 5º) porque si no hace estos circulos. A ver si este fin de semana puedo ajustarla bien y mirar que no tenga alguna inteferencia magnetica y os cuento si se arregla.

    Un saludo.
     
  4. trokola Miembro

    trokola
    Registrado:
    18 Dic 2008
    Mensajes:
    414
    Me Gusta recibidos:
    0
    Bueno, finalmente los circulos que hacia en el Hold position (y ahora veo que el return home no funcionaba bien tampoco), efectivamente eran por problemas en la brujula. Tenia una interferencia magnetica al arrancar los motores que provocaban a veces hasta 20º de error en el rumbo. He puesto mas altas las placas de Nav, gps y mag, con el fin de separarlas del cableado de los motores y ahora al arrancar motores el rumbo oscila 2 o 3º nada mas. Ahora el PH y RH funconan muchisimo mejor.
     

Compartir esta página